Website unavailability
Incident Report for Curve
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 15:08 UTC
Investigating
We are currently investigating an issue with the curve.com website which may impact some aspects of the mobile application, including authentication and referrals.
Posted Apr 30, 2024 - 08:52 UTC
This incident affected: In-app Curve functionality.